Twitter Login not working
Incident Report for Kialo
Resolved
Twitter login is working again.
Posted 11 months ago. Jun 13, 2018 - 08:00 UTC
Investigating
We are currently experiencing issues with Twitter logins. If you cannot login via Twitter, please use one of the alternative methods in the meantime. You can create a password for your account by using the "Forgot password" link on the login page if you have exclusively used Twitter login in the past. Please apologise the inconvenience, we are trying to fix the issue as quick as possible.
Posted 11 months ago. Jun 13, 2018 - 06:48 UTC
This incident affected: www.kialo.com (Web Application).