Degraded Mail Performance
Incident Report for Kialo
Resolved
This incident has been resolved.
Posted almost 3 years ago. Nov 03, 2016 - 15:02 UTC
Monitoring
Mails from Kialo may be delayed for a few minutes. We are monitoring the situation while our mail provider works on a solution.
Posted almost 3 years ago. Nov 03, 2016 - 14:06 UTC